CoolStar обновляет libhooker до версии 1.3.0 с оптимизацией памяти и многим другим

Cydia Substrate — не единственный инжектор настроек, который в последнее время получает новые обновления. Libhooker, главный метод внедрения настроек для джейлбрейка Odyssey на базе iOS 13 и скрипта Odysseyra1n для джейлбрейка checkra1n, только что получил новое обновление до версии 1.3.0 с некоторыми заметными улучшениями.

Ведущий разработчик Odyssey Team CoolStar объявил о выпуске обновленного libhooker в субботу вечером через Twitter, и далее описал обновление и все, что оно приносит, на официальном канале Discord:

Насколько нам известно, libhooker v1.3.0 содержит следующие изменения:

— Оптимизация хуков Objective-C, чтобы использовалось меньше памяти (приносит пользу для всех настроек)
— Оптимизация обработчиков C для настроек, которые обновляются для прямого использования API libhooker, чтобы использовалось меньше памяти (например, Anemone 3)
— Исправлена ​​ошибка, из-за которой крючки в некоторых случаях не работали на iPhone 5S и 6 с iOS 12. [this fixes newer Anemone 3 and RocketBootstrap on these devices with Odysseyra1n/Procursus-Chimera]

Как вы, наверное, уже заметили, это обновление содержит множество оптимизаций и исправлений ошибок, которые должны сделать перехват более надежным и стабильным. После этого обновления он не только экономит системные ресурсы, но и решает проблемы с устройствами, которые не оснащены таким объемом памяти, как некоторые из новых телефонов Apple.

Если вы используете джейлбрейк Odyssey или скрипт Odysseyra1n для взлома checkra1n, то последнее обновление libhooker должно быть доступно через репозиторий Odyssey по умолчанию через ваш любимый менеджер пакетов и рекомендуется для всех пользователей этих джейлбрейков. Очевидно, это не относится к стандартным пользователям checkra1n или пользователям unc0ver, поскольку в этих джейлбрейках вместо этого используется Cydia Substrate и / или Substitute для внедрения настроек.

Стоит отметить одну вещь: если вы тестировали бета-версию libhooker v1.3.0 до сегодняшнего официального обновления, то официальное обновление может не появиться для вас. Если это так, CoolStar рекомендует удалить бета-репозиторий и использовать жест 3D Touch / Haptic Touch на кнопке «Изменить» в Sileo, чтобы убедиться, что вы установили последнюю версию. Это должно исправить ситуацию и позволить вам установить официальный публичный выпуск libhooker v1.3.0.

Вы уже обновили libhooker на своем устройстве Odyssey или Odysseyra1n? Поделитесь в разделе комментариев ниже.

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *